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RiseClipse Guide — Installation and OCL (25 may 2021)
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Modify or add an OCL constraint in GitHub, from Eclipse ........cccoevviieviiiiiieiieee e,

GitHub address : https://github.com/riseclipse/riseclipse-ocl-constraints-scl2003

Download and install Eclipse Modelling
Install Eclipse Modelling 2019-06 : 2019-06 R | Eclipse Packages

Install the necessary plug-ins
To install a plugin in Eclipse, go to: Help -> Install New Software

click on “What is already installed”, and check if the following points are intalled,
otherwise, install them :

In “Work with” put : 2019-06 - http://download.eclipse.org/releases/2019-06

select the plugins to install :

Eclipse SDK

Eclipse Project SDK

EMF — Eclipse Modeling Framework SDK

OCL Examples and Editors SDK

OCL Examples and Editors SDK developper resources
EMF Validation Framework SDK

UML2 Extender SDK

O O 0O O O O O

Import data from GitHub

After all the initial requirements are met, it is possible to import the GitHub projects into Eclipse.

In Eclipse, first go to Window -> Show View -> Other... -> Git -> Git Repositories
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Show View -

type filter text

> = Ant ~
= APl Tools

= Code Recommenders

= CVS

= Debug

[= Eclipse Modeling Framework

= General

4 [= Git

. = Gradle
: = Help W

yli Git Interactive Rebase
& Git Reflog

wrl Git Repositories

£y Git Staging

lair Git Tree Compare

A tab for the Git repositories will then be present in the layout of the Eclipse.

You must then import the following projects from GitHub :

riseclipse-ocl-constraints-scl2003
riseclipse-metamodel-scl2003
riseclipse-main

riseclipse-editor
riseclipse-metamodel-nsd2016

In Eclipse, choose the option “Clone a Git Repository” and put the HTTPS link from the Github into the
“URI” box. The “Host” and “Repository path” should complete themselves automatically. Set the
Connection Protocol to https and fill the GitHub User and Password in the Authentication.

https://riseclipse.github.io/
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Pull requests Issues Marketplace Bxplore

& riseclipse / riseclipse-ocl-constraints-scl2003 © Unwat
<> Code () lssues 6 I'L Pull requests () Actions [ Projects 0 wiki ) Security [~ Insights €1 Set
P master - B 6 branches 0 tags Go to file Add file ~
ADehouck Merge pull request #15 from riseclipse/Bug_correction_Control bJ  Clone ®
HTTPS 55H GitHub CLI
fr.centralesupelec.edf.riseclipseiecé1..  Correction of issue #14 https://github.com/riseclipse/riseclipse (|
[ ISSUE_TEMPLATEmd Create ISSUE_TEMPLATE.md Use Git or checkout with SYN using the web URL.
[ LICENSE Upload EPL 2.0
fé] Open with GitHub Desktop
[ README.md all available written OCL constrai
[ Download ZIP
:= READMEmd »
S Clone Git Repository O X
Source Git Repository GIT
Enter the location of the source repository. == 4
Location
URI: | b.com/riseclipse/riseclipse-ocl-constraints-scl2003.git | | Local File...
Host: | github.com |

Repository path: | [niseclipse/riseclipse-ocl-constraints-scl2003.git |

Connection

Protocol: | https ~

Authentication

User | |

Password: ssssssssas |

[ Store in Secure Store

@ < Back Finish Cancel

After cloning all the mentioned repositories, the Git Repositories tab should end up like bellow :

https://riseclipse.github.io/
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= Qutline 5 Git Repositories &2

[ riseclipse-developer [master] - T\ Users\i27

riseclipse-distribution [master] - C\sershiz
= riseclipse-editor [master] - C\Usershi2775
= riseclipse-rnain [master] - 0O Usershi2775
= riseclipse-metarmodel-nsd2016 [master] -
= riseclipse-metamodel-scl2003 [master] -

= T == 1= 1=

riseclipse-ocl-constraints-scl2003 [rmaster] -
[1 = riseclipse-validator-ocl [rmaster] - C:\User
[1 = riseclipse-validator-scl2003 [master] - C

To import the projects, right click on every repository and “Import Projects...”.

B Model Explorer &3

|t_-,rpe filter text

=% fr.centralesupelec.edf.riseclipse.developer.documentation [rizeclipze-
=% fr.centralesupelec.edf.riseclipse.developer.eclipse [rizeclipse-develop:
% fr.centralesupelec.edf.riseclipse.developer.pZ_to_md [rizeclipse-devel
'[L—"él- » fr.icentralesupelec.edf.riseclipse.editor [rizeclipse-editor master]
% fr.centralesupelec.edf.riseclipse feature.cim.cim16.entsoe [rizeclipse-
=% fr.centralesupelec.edf.riseclipse feature.cim.cim16.entsoe.edit.editor |
=% fr.centralesupelec.edf.riseclipse.feature.editor [riseclipse-distribution
=% fr.centralesupelec.edfiriseclipse feature.iec61830.scl [riseclipse-distrib
=% fr.centralesupelec.edf riseclipse feature.iecG1830.scleditor [riseclipsze-
'[L—"él- = fr.centralesupelec.edfriseclipse.iec61850.nsd [riseclipse-metamode
'[L—"él- = fr.centralesupelec.edfriseclipse.iect1850.nsd.edit [riseclipse-metar
'[L—"él- = fr.centralesupelec.edfriseclipse.iect1850.nsd.utilities [riseclipse-me
Tij"él- = fr.centralesupelec.edfriseclipse.iect1850.scl [riseclipse-metamodel-
'[L—"él- = fr.centralesupelec.edfriseclipse.iect1850.scl.edit [riseclipse-metam:
=% fr.centralesupelec.edfriseclipse.iect1830.scl.ocl [riseclipse-ocl-constr
'[L—"é'- = fr.centralesupelec.edfriseclipse.iect1850.sclutilities [riseclipse-met
'[L—"é'- = fr.centralesupelec.edfriseclipse.iect1850.sclvalidator [riseclipse-val
'[L—"é'- = fr.centralesupelec.edfriseclipse.iect1850.sclvalidator.ui [riseclipse-
Tij"é'- = fr.centralesupelec.edfriseclipse.main [riseclipse-main master]

=% fr.centralesupelec.edf.riseclipse.update-site [riseclipse-distribution m
'[L—"é'- » fr.centralesupelec.edfriseclipsevalidation.ocl [riseclipse-validator-:

o= Outline E] Git Repositories 53 = | =

[ riseclipse-developer [master] - C:\Users\i277534 gitS\riseclipse-develo

[ riseclipse-distribution [master] - C\Users\i27754\ gitS\riseclipse-distri

[ = riseclipse-editor [master] - C\Users\i27754\ gitS\riseclipse-editori.g
[ = riseclipse-main [master] - C:\Users\i27754\gitS\riseclipse-main'. git

[1 = riseclipse-metamodel-nsd2016 [rmaster] - C\Usersti2

773 git3hrises

[1 = riseclipse-metamodel-scl2003 [rmaster] - C\Users\i2 77

ShgitShrisec

[ riseclipse-ocl-constraints-scl2003 [master] - C\Users\i2 7754 git5hrise

[ = riseclipse-validator-ocl [master] - C:\Users\i27754\git5\riseclipse-vi

[1 = riseclipse-validator-scl2003 [master] - C\Users\i2 7754\ gitSriseclip:

https://riseclipse.github.io/
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Launch RiseClipse editor as an Eclipse Plugin
Select fr.centralesupelec.edf.riseclipse.editor in the Model Explorer,

Go to Run menu, and select “Run configuration”, then select Eclipse Application, and click on “Run”

This error can be ignored (click on “continue”)

2 Validation x

The following problems were detected:

i) javaxxml.bind:

= org.eclipse. pp..logging.aeri.ide

In the new Eclipse instance, create a project / empty OCL project
You can drag&drop your SCL files and OCL files in the Project Explorer.

Then, to open the SCL file, right click on it, “Open with” / “other”, and select “RiseClipse Model
Editor”

S Editer Selection Od =

Choose the editor for cpening
[OP_2019_HV_v3 ed2.1.scd:

(®) Internal editors () External programs

type filter text

Meo Source Found ~
OCLinEcore Editor

OCLstdlilb Editor

Plug-in Manifest Editor

Product Cenfiguration Editor

Properties File Editor

RiseClipse Model Editor

Sample Ecore Model Editor

@ Sample Reflective Ecore Model Editor

L&l Sample Reflective Ecore XML Model Editor
-

ol (R W T o | [ )

BemheEs=

Browse...

[] Use this editor for all '[OP_201%_HY_v8_ed2.1.scd’ files
[JUse it for all *.scd" files

This opens the file, and you can visualize every element, and the properties of each element, and
with the links that are built by RiseClipse.

https://riseclipse.github.io/
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[} 10P_2019 HV v@ ed2.l.scd 52

r[\:, Resource Set

W l@ platform:/resource/SCL/model/IOP_2019_HV_v8_ed2.1.5cd

w 4 SCL2
<4 Private 3
4 Private 15
< Header
w & |ED L1_BCU_SIF_200E
w 4 Access Point 51
w < Server 1815
4 Private 1816
< Authentication 1817
w 4 LDevice L1_BCU_SIF_200ELDO
~ < LNOIEC 61850-7-4:2007
~ 4 DOl Beh
v <= DAl stVal
4 Val 2196

Tazks [ Properties &3 References
Property

Desc

Explicit Links Built

Inst

Line Number

Ln Class

Ln Type

Mamespace

Referred By Association
Referred By Client LM
Referred By IED Name
Referred By LNode
Referred By Log Control
Refers To LNode Type

Copyright (c) 2021 CentraleSupélec & EDF

i
Value
'= General
Uk true
1819
LLNO

SF_CSD_V2.01_LLMNO
IEC 61850-7-4:2007

% Log Control LeblLogh, Log Control LebLogB
# LNode Type SF_CSD_VZ.01_LLND

You can navigate inside the file, using the links and references built by RiseClipse, by selecting an
object / right click / Selected object / Navigate to...

https://riseclipse.github.io/



https://riseclipse.github.io/

risecCLIPSE
Copyright (c) 2021 CentraleSupélec & EDF

& 1OP_2019_HV_v9_ed2.1.5cd [9) ReportControl.ocl % GEICT.scd &2
‘) Resource Set
v platform/resource/SCL/mode|/GEICT.scd
~ 4+ 5CL2
4 Header GEICT
~ 4 |ED CEBT
+ Private 118
+ Private 13812
4 Private 13813
v Access Point $1
~ + Server 13863
4+ Authentication 13864
~ 4 LDevice CBTMaster

PR
New Child »
New Sibling >
Undo Ctri+Z
Redo
4 Cut
Copy
Paste
X Delete
Validate
Contro
Selected object > MNavigate to » RefersToLNodeType > LNode Type LLNO_O |
O RunAs » Dol >
= Properties 5 Debug As 3 ReportControl »
Team » DataSet »
Property Compare With > GSEControl H
Dese Replace With » ParentLDevice >
Explicit Links Built ~ ~ N
& Show EClass information SettingControl 3
Inst = Show References
Line N '
ine Number ocL ~ ’ 13866
Ln Class “LLNO
Ln Type Load Resource... FLLNOD
Namespace Refresh o
Referred By Associal  show Properties View
Referred By Client Lt ) ) ) ) =
Remove from Context Ctrl +Alt+Shift+Down 5
Referred By IED Nan .
Referred By LNode =
Referred By Log Control -
Refers To LNode Type * LNode Type LLNO_O

In order to access the existing RiseClipse OCL files, it is possible to import the git project riseclipse-
ocl-constraints-scl2003 into this second Eclipse instance.

In Eclipse, go to Window -> Show View -> Other... -> Git -> Git Repositories

Click on the first icon : “Add an existing local Git repository to this view”

Validate a SCL file with an OCL file

To validate a file with an OCL file, right click on the root element, and click on OCL / Load document.

https://riseclipse.github.io/
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(4 10P_2019_HV v@_ed2.1.scd 52
r[‘j Resource Set

v [B] platform:/respen/er1 fommdnl IO A6 L s o 1 e
~ & SCL2 Undo Cerl+Z
<4+ Private Redo Ctrl+Y
4 Private
<+ Header Cut
v 4 DL [E Copy
v & Acce Paste
v s
4 Delete
¥ Validate
My
v
@ Runis >
45 Debug As >
Team >
Compare With >
Replace With >
ocL > Validate
Load Resource... Export Document
Tasks |5 Prope e
Refrech [0] Load Document
Property e
Show Properties View Gt Show Xtext OCL Console
Gl ShowOCLC " Load Complete OCL Document to contribute validation ‘
Remove from Context Ctrl+Alt+Shift+Down b ow onsele
[ Show Validity View
%5 Debug...

Select the OCL file in the workspace, or in the file system,

The OCL file is loaded bellow the SCL file :

3 10P_2019_HV v9_ed2.1.scd 53

r|>_‘| Resource Set

@ platform:/resource/SCL /model/IOP_2019_HV_v3_ed2.1.5cd
[0] platform:/resource/SCL/model/ReportControl.ocl

Select the SCL root, right click / Validate

@ 10P_2019_HV_v9_ed2.1.sed 3 @ ReportControl.ocl
r(}j Resource Set
@ platform:/resource/SCL/model/IOP_2019_HV v9_¢

Undo Ctrl+Z
[6] platform:/resource/SCL/model/ReportControl.ocl

Redo Ctrl+Y
Cut

[E Copy
Paste

Delete

Validate
Control...
Run As
Debug As

Team

# 0O

Compare With
Replace With
ocL

N

Load Resource...
Tasks [C] Properties 3 + References
Refresh

=]
roperty Show Properties View He

Remove from Context Ctrl+Alt+Shift+ Down

If the file does not respect the constraints defined in the OCL file, the errors will appear:

https://riseclipse.github.io/
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& Validation Problems *

Problems encountered during validation

i
=== Reason:

Diagnaosis of 5CL 2

o [EEE]

ERROR:[SemanticConstraints] confRev attribute in RepertContrel equals zero only fo A
ERROR:[SemanticConstraints] confRev attribute in ReportControl equals zero only fo
ERROR:[SemanticConstraints] confRev attribute in ReportContrel equals zero only fc
ERROR:[SemanticConstraints] confRev attribute in ReportContrel equals zero only fc
ERROR:[SemanticConstraints] confRev attribute in ReportControl equals zero only fc
ERROR:[SemanticConstraints] confRev attribute in RepertControl equals zero only fc
ERROR:[SemanticConstraints] confRev attribute in ReportControl equals zero only fo
ERROR:[SemanticConstraints] confRev attribute in ReportControl equals zero only fo
ERROR:[SemanticConstraints] confRev attribute in ReportContrel equals zero only fc
ERROR:[SemanticConstraints] confRev attribute in ReportContrel equals zero only fo v
< >

Using the OCL console

An easy way to help building new OCL constraints, is to use the OCL console :

Select an element in the SCL, right click / OCL / Show XText OCL Console

[} 10P_2019 HV w0 ed2.1.scd 7 | [6] ReportControl.ocl

1) Resource Set
~ 4 IED L1_BCU_SIF_200F
v 4 Access Point 51
v 4 Server1815
<4 Private 1816
4 Authentication 1817
v 4 LDevice 200

~ 4 LNO
v & D ?
v+ New Sibling >
Undo ez
4+ D
&0 Redo culey
+ 0 cut
0.
40 B Copy
4D Paste
4D % Delete
4+
4D Validate
+0D Control
asks [F] Properties 52 Selected object >
P Val
roperty Q FRunas > elue
Desc = General
Explicit Links Built 4 Debugas >
Inst Team >
Line Number Compare With >
Ln Class Replace With >
nT F_CSD_V2.01_LLNOD
e % Show EClass information e
amespace 7.
Referred By Association = Show References =
Referred By Client LM ocL > Validate

Referred By IED Name
Referred By LNede

Referred By Log Control Refresh a
Refers To LNode Type

Load Resource... Export Document

Load Document blogA, Log Control LebLogB

Show Properties View B3 ShowXtext OCL Console -CSDVZOLLLMD

Remove from Context Cti+AltsShift+ Down | B Show OCL Console
[%  Show Validity View

Debug..

You can type OCL code in the console, and the result will be displayed (note that the context — the
selected element in the SCL — is important)

https://riseclipse.github.io/
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@ IOP_201%_HV v9 ed2.l.scd i3 ReportControl.oc

r[\j Resource Set

w < |ED L1_BCU_SIF_200E
~ 4 Access Point 51
v < Server 1815
4 Private 1816
< Authentication 1817
w 4 LDevice L1_BCU_SIF_200ELDO
w < LNOD [EC 61850-7-4:2007
w 4 DOl Beh
w = DA stial
4 Val 2196
4 DOl Health
% DOl Loc
4 DOl RemSetEna
4 DOl RemnGrpEna
< DOl RemGoEna
4 DOl Mod
< DOILEDRs
4 DOl FuncEnal
4 DOl FuncEna2
< DOl FuncEna3
4 DOl FuncEnad
< DOl FuncEnad
4 DOl FuncEnat
4 DOl FuncEna7
< DOl FuncEna8

»=| Tasks [] Properties = References B Console 53
Ktext OCL for 'SCLuIED:AccessPoint:Server:LDevice:LIND' : LINO

Evalunating:
self.1lnType
Results:

'SF_CSD v2.01 LLNO"

self.lnType|

Modify or add an OCL constraint in GitHub, from Eclipse

First, you should create an Issue in GitHub, describing what you want to add or correct

Click on “New Issue” and describe the change as precisely as possible, and refer to the corresponding
document (standard, TISSUE...)

https://riseclipse.github.io/
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Team Enterpi Explore

& riseclipse / riseclipse-ocl-constraints-scl2003 ar
Code (@ Issues 4 Pull requests Actions Projects Wiki Security Insights
@© 40pen + 5 Closed Author~  Label~  Projects~  Miestones~  Assignee~  Sort~

© New constraint to add : in ReportControl, check that intgPd is only set if and only if trigger option period is set to true

#10 opened on 14 Apr by ADehouck

Then, in Eclipse, you need to get the latest version of the code that is on Github (It might have been
modified by other people).

In Git Repository tab, select : riseclipse-ocl-constraints-scl2003

Right click / Pull

|t_ype filter text

I fr.eentralesupelec.edf.riseclipse.deve & SwitchTo y
=% fr.centralesupelec.edfuriseclipse.deve

1% frcentralesupelec.edfuriseclipse.deve <] Commit... Ctrl+ &
Ic# > fr.centralesupelec.edf.riseclipse.ed
i fr.centralesupelec.edfuriseclipse feat
I fr.centralesupelec.edf.riseclipsefeat,
I fr.centralesupelec.edfuriseclipsefeat
L% fr.eentralesupelec.edf.riseclipse featu
I fr.centralesupelec.edfuriseclipsefeat
= fr.centralesupelec.edf.riseclipse.iec L

- fr.centralesupelec.edfriseclipseiec Pull...

= fr.centralesupelec.edf.riseclipse.iec Remote >
- fr.centralesupelec.edfriseclipse.ec
= fr.centralesupelec.edfriseclipseiec
fr.centralesupelec.edfriseclipseecs | Rebase...
= fr.centralesupelec.edf.riseclipsee .28 Reset...
= fr.centralesupelec.edf.riseclipse.ec

= fr.centralesupelec.edf.riseclipseiec =1
= fr.centralesupelec.edf.riseclipse.m
fr.centralesupelec.edf.niseclipse.updi

= fr.centralesupelec.edfriseclipseva C&  Clean...

il Collect Garbage

Stashes »

4 Pushto Upstream er]
4 Fetch from Upstream
4 Push Branch 'master'...
ol
ot

Merge...

Import Projects...

Show In Alt+Shift+W »

POORLESRTRRE

Remove Repository from View

alidator-ocl.git

~ riseclipse-validator-ocl [master] - C\U
C pse-validator-s

= riseclipse-validator-scl2003 [master]

5= Outline | 5 Git Repositaries 53 3¢ Delete Repository... B Y=
[ riseclipse-developer [master
iseclipee-developer [mectarl Add Submedule...
[ riseclipse-distribution [master
[ = nsechipse-editor [master] Copy Path to Clipboard Ctrl+C
0 » riseclipse-main [master] - =0 Paste Repository Path or URI CHri+V
[] = riseclipse-metamodel-nsd2016 [m -git
[ = riseclipse-metamodel-scl2003 [m:z Properties Alt+Enter it
| riseclipse-ocl-constraints-scl2003 [master] =~ CUSErsTZ T T3 git S Asecipse- ocl-constramnts-sclZ003. git
a
[0}

(for members of the project only — else do a Fork and pull model
https://docs.github.com/en/github/collaborating-with-issues-and-pull-requests/getting-
started/about-collaborative-development-models)

Create a new branch, and switch into it : right click / Switch to / New branch

https://riseclipse.github.io/
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==

& Mode! Explorer {3 == |

ype filter text |

(&% fr.centralesupelec.edf riseclips

T s L&
(&8 fr.centralesupelec. edf iseclips S5 SMIECH 19 <4 DBl
1% fr.centralesupelec edf riseclip: 2 Commit. Ctri+2 master
S
(e > frcentralesupelec.edf isecl i N on
1% fr.centralesupelec.edf riseclip: ther...
(e fr.centralesupelec.edf riseclip: & Push to Upstream | master]
% frcentralesupelec.edfriseclip: ) Fetch from Upstream
55 frcentalesupelec.edfisecip: o gk st
(e fr.centralesupelec.edf riseclip:
& > fr.centralesupelec.edfrisect @ Pull
&7 > fr.centralesupelec.edf.risecl 40~ Pull ]
(&4 > frcentralesupelec.ed.risecl Remote > bster]
154 > fr.centralesupelec.edf.risect
12 > frcentralesupelec.edrisecl ©  Merge 29
(2 frcentralesupelec.edfriseclip: 1) Rebase.. e
(&4 > fr.centralesupelec.edfisecl <0 Reset.. er] 2
2 > fr.centralesupelec.edf.risect ] 33
&2 > frcentralesupelec.edf.risecl £23 Import Projects.. Eter] 31
54 > fr.centralesupelec.edf.risect —— AT j»
1 fr.centralesupelec.edf riseclip: s
J o ) 37
(&4 > frcentralesupelec.edtrisec] (3 Clean.. ol
M Collect Garbage 39
/7 Remove Repository from View "
£ Outline |9 Git Repositories 17 g Delete Repository. EE Y =8
[ riseclipse-developer [master] 23
B - Add Submodule... a
[ riseclipse-distribution [mastel a4
43
0 > riseclipse-editor [master] - { Copy Path to Clipboard Ctrl+C 45
Q > riseclipse-main [master] - § Paste Repository Path or URI Ctrl+V 47
[ > riseclipse-metamodel-nsd2 g a2
[ » riseclipse-metamodel-scl20  Properties Alt+Enter
(7 riseclipse-ocl-constraints-scl2vos trmast
[ » riseclipse-validator-ocl [master] - C:\Us
<tern

[ > riseclipse-validator-scl2003 [master] - C

Implement the new constraint or correct an existing one.

Then, you need to commit the change: right click / Commit.

The list of your changes will be shown in the “Unstaged Changes” tab,

Use the green cross “+” to add you changes into the “Staged changes”

You should then write a “Commit message” that references the issue number that you implement

Then, click on “Commit and Push”

Go to the GitHub webpage, and create a “Pull request”

Your code will be reviewed, accepted, and the issue closed

https://riseclipse.github.io/
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